Сдам Сам

ПОЛЕЗНОЕ


КАТЕГОРИИ







Б).Размещение посевов сельскохозяйственных культур в программе





MS Excel

Размещение посевов сельскохозяйственных культур произведено на примере пахотных земель второй бригады. Общая площадь пашни здесь составляет 642,5 га.

Для размещения посевов сельскохозяйственных культур в программе MS Excel были использованы следующие исходные материалы:

- матрица чистого дохода на 1 га у.е. (приложение 3)

- сведения о предшественниках сельскохозяйственных культур по рабочим участкам (табл.15.1);

- информация о площадях посева сельскохозяйственных культур в бригаде №2.

 

Таблица 15.2. Сведения о рабочих участках пахотных земель в бригаде №2

 

№ участка Площадь, га Предшественник Общая оценка, у.е./га Категория пригодности
195,9 Яров. зерновые 147,8 3.Хорошие
21,3 Яровые зерновые 165,3 2.Благоприятные
27,0 Многолетние травы 208,7 2.Благоприятные
25,1 Зернобобовые 167,9 2.Благоприятные
9,6 Корнеплоды 146,3 3.Хорошие
33,7 Кукуруза 120,0 3.Хорошие
21,9 Яровые зерновые 151,4 3.Хорошие
21,7 Озимые зерновые 103,2 3.Хорошие
26,8 Многолетние травы 167,0 2.Благоприятные
50,5 Однолетние травы 135,3 3.Хорошие
115,6 Озимые зерновые 185,5 2.Благоприятные
76,1 Многолетние травы 189,9 2.Благоприятные
5,3 Картофель 31,5 4.Удовлетворительные
12,0 Лен 130,0 3.Хорошие

 

Технология размещение посевов сельскохозяйственных культур по рабочим участкам (транспортная задача закрытого типа) заключается в следующем. Вначале выделяем область, в которой будут приведены площади посева сельскохозяйственных культур (xij – площадь посева i–й культуры на j–том участке) (рис.15.109.).

Рис.15.109. Область листа Excel, в которой будет производиться размещение посевов



 

Затем выделяем область под значения коэффициентов при неизвестных значениях (рис.15.110.).

Рис.15.110. Область листа Excel, в которую вносятся данные матрицы эффективности

 

После этого формируем перечень уравнений в соответствии с формулами:

1) Σ А32:I32 = 642.5

2) Σ К17:К30 = 642,5

3) Z = СУММПРОИЗВ(A17:I30;A35:I48)

Вносим в колонки площади участков и площади посевов. Нижние две строки указывают площади посева культур в соответствии со структурой посевных площадей, а крайние правые два столбца указывают площади рабочих участков (рис. 15.111.).

Рис. 15.111 Таблица расчета посевных площадей

 

Вносим в нижнюю область значения чистого дохода с учетом коэффициента пересчета за предшественников и сроки возврата (рис.15.112.). Коэффициенты взяты из методических указаний [12].

Рис. 15.112. Матрица чистого дохода с учетом предшественников и срока возврата сельскохозяйственных культур на прежнее место

 

Матрица доходности возделывания сельскохозяйственных культур по рабочим участкам передана из атрибутивной таблицы созданной Темы «пахотные земли» ГИС ArcView.

Далее выбираем опции Меню│Сервис команду Поиск решения (рис.15.113).

Рис.15.113. Окно Меню│Сервис

 

В появившемся окне устанавливаем целевую ячейку L33, которая является целевой функцией Z = СУММПРОИЗВ(A17:I30;A35:I48), т.е. сумма произведений значений условного чистого дохода на соответствующие значения посевных площадей (рис. 15.114).

Рис. 15.114. Диалоговое окно «Поиск решения»

 

В диалоговом окне Поиск решения целевую функцию будем находить по максимальному значению. В соответствующем окошке указываем ячейку, где будет рассчитана целевая функция.

Область изменений ячеек указываем равной области, занимаемой значениями посевных площадей (рис. 15.111.).

В окне «Ограничения» указываем необходимые для поиска решения ограничения, т.е. сумма площадей посевов всех культур должна быть равной площади всей пашни; сумма площадей всех рабочих участков также должна быть равной площади всей пашни.

Далее выбираем команду Выполнитьи автоматически получаем значение целевой функции равное 83736,2 у.е.

Результаты размещения посевов отображаются в ArcView двумя способами.

Первый способ заключается в том, что в Excel выбирается опция Файл │Сохранить как … .В этой опции необходимо осуществить выбор типа файла. Как правило, это форматы баз данных dbf (dBase I–IV), wq (Quattro Pro) (рис. 15.115).

Рис. 15.115. Окно передачи данных из форматов Excel в форматы баз данных

 

Далее в ГИС ArcView в опции Таблицы выбирают Добавить,после чего появляется атрибутивная таблица, которую можно присоединить к существующим базам данных.

Второй способ заключается в том, что в опции Меню│Вид выбирается Новая тема, которую преобразуют в щейп-файл («размещение посевов»).

Затем в атрибутивную таблицу добавляем новое поле «культуры», где напротив каждой площади поля подписываем название соответствующей культуры (рис.15.116).

.

 

Рис.15.116. Фрагмент атрибутивной таблицы «размещение посевов на перспективу»

 

Затем каждой культуре присвоили свой цвет и сделали надписи па каждом поле с указание площади (рис.15.117).

 

Рис.15.117. Результат размещения посевов сельскохозяйственных культур в бригаде 2

 

Таким образом, ГИС ArcView является довольно мощным средством выполнения подготовительных работ при разработке проектов внутрихозяйственного землеустройства (вычисление площадей, выполнение зонирования территории и некоторые другие операции). В тоже время она ограниченно может использоваться для решения оптимизационных задач. Поэтому необходимы исследовательские работы по изучению необходимости применения ГИС ArcView для решения задач минимизации расстояний на перевозку грузов, перегонов скота и других задач оптимизационного характера.

 

 









Не нашли то, что искали? Воспользуйтесь поиском гугл на сайте:


©2015- 2019 zdamsam.ru Размещенные материалы защищены законодательством РФ.